jump to navigation

Siguiendo la pista octubre 18, 2016

Posted by ximo88 in Linux, SOs/OSes.
trackback

captura-de-pantalla_2016-10-18_09-37-26

Web OS

3737ª Parte Siguiendo la pista

alien

packageconverter

googlecode-foxoman

Hablando de snap la semana pasada mencioné de pasada a alien y package converter si bien con el primero no hay problemas en las versiones de 64 y 32 bits si parece que las hay con package-converter yo estoy usando una distro de 64 bits y el problema es que el package DEB lo instalo sin mayor problema, sale que todas las dependencias se cumplen,  pero al ir a lanzarlo me sale algo como esto:

ximo@ximo-SN10E100:~$ package-converter
./Package-Converter: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

Pienso que a lo mejor es simplemente que la librería no la encuentra normalmente es un enlace simbólico a otra librería dinámica e intento buscarlo en concreto abro el synaptic y busco esa librería la libgtk2.0, abro propiedades y luego archivos instalados y veo que está instalada.

captura-de-pantalla_2016-10-18_10-57-40

/.
/usr
/usr/lib
/usr/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu/gtk-2.0
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-am-et.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-cedilla.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-inuktitut.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-ipa.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-multipress.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-thai.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-ti-er.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-ti-et.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-viqr.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-xim.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/printbackends
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/printbackends/libprintbackend-file.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/printbackends/libprintbackend-test.so
/usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0
/usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0.2400.30
/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0.2400.30
/usr/lib/x86_64-linux-gnu/libgtk2.0-0
/usr/lib/x86_64-linux-gnu/libgtk2.0-0/gtk-query-immodules-2.0
/usr/lib/x86_64-linux-gnu/libgtk2.0-0/gtk-update-icon-cache
/usr/share
/usr/share/doc
/usr/share/doc/libgtk2.0-0
/usr/share/doc/libgtk2.0-0/AUTHORS
/usr/share/doc/libgtk2.0-0/NEWS.gz
/usr/share/doc/libgtk2.0-0/README.Debian
/usr/share/doc/libgtk2.0-0/README.gz
/usr/share/doc/libgtk2.0-0/changelog.Debian.gz
/usr/share/doc/libgtk2.0-0/copyright

A continuación lanzo el Midnight Commander o mc  con sudo para buscarlo y hacer otro enlace donde pueda encontrarlo mas fácilmente en concreto lo hago a /usr/lib.

Lo lanzo de nuevo el package-converter (hay y va desde icono pero en teoría …) y me sale lo siguiente:

ximo@ximo-SN10E100:~$ package-converter
./Package-Converter: error while loading shared libraries: libgtk-x11-2.0.so.0: wrong ELF class: ELFCLASS64

Ahora no uso distro de 32bits y en teoría no debe de dar problemas la versión que se pille para bajar de package-converter en este tipo de distro la de 32bits pero en 64 bits no funciona ná de ná que conste que es solo el frontend llamado package-converter no el alien.🙂 Ximo

Comentarios»

No comments yet — be the first.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: